Knowledgebase
What new dependencies does Train Simulator 2019 64-bit use?
Posted by DTG Support DM on 12 October 2018 08:45 AM

The 64-bit version of the game requires the following dependencies(redistributables) to be installed.

Just click the links below, then the Download button and follow the instructions to install:

https://www.microsoft.com/en-gb/download/details.aspx?id=8109 Please note you will need to open the folder you have extracted this into and run the DXSETUP application.

https://www.microsoft.com/en-gb/download/details.aspx?id=14632

https://www.nvidia.com/object/physx-9.12.1031-legacy-driver.html